X
margaratappan
margaratappan en 2012

 Firefox 12.0

instalé este nuevo firefox y tambien googlechrome pero sale una leyenda de que la aplicación no puede usarse con la versión de la Mac OS que tengo. ¿Qué puedo hacer?